Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10068 closed defect (worksforme)

libgcc lunaro-79 x86 router not installed

Reported by: Andrey Popov <admin@…> Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: libgcc installation Cc:

Description

after upgrade libgcc to lunaro-79 it always says package mark HOLD and the try upgrade or install (--force-reinstall) give error:

 1277 root         0 SW   [jbd2/sda4-8]
 1279 root         0 SW<  [ext4-dio-unwrit]
 1347 root         0 SW   [jbd2/sdc1-8]
 1348 root         0 SW<  [ext4-dio-unwrit]
 1417 root         0 SW   [jbd2/sdb1-8]
 1420 root         0 SW<  [ext4-dio-unwrit]
 1803 root       684 S    /usr/sbin/ntpclient -i 600 -s -l -D -p 123 -h 0.open
 1819 root      1232 S    hostapd -P /var/run/wifi-phy0.pid -B /var/run/hostap
 2155 root         0 SW   [flush-8:16]
 2156 root         0 SW   [flush-8:32]
 2169 root      1032 S    crond -c /etc/crontabs -l 5
 2186 root       820 S    /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
 2203 root      1052 S    /usr/sbin/uhttpd -f -h /www -r CS-Internet-App -x /c
 2212 root      2056 S N  smbd -D
 2274 root      1600 S    lua -lluci.lucid -e luci.lucid.start()
 2279 root     11888 S    /usr/sbin/collectd -f
 2288 nobody    1200 S    memcached -d -u nobody -c 1024 -l 0.0.0.0 -p 11211 -
 2293 root      6672 S <  /opt/usr/sbin/named -4 -c /etc/bind/named.conf
 2301 nobody    1412 S <  proftpd: (accepting connections)
 2474 root     36964 S N  /usr/bin/transmission-daemon -g /opt/transmission
 2713 root       892 S    /usr/sbin/dropbear -P /var/run/dropbear.1.pid -p 22
 2726 root      1032 S    -ash
 2772 root      1024 R    ps
root@CS-Internet-App:~# opkg update
Downloading http://downloads.openwrt.org/snapshots/trunk/x86/packages/Packages.gz.
Inflating http://downloads.openwrt.org/snapshots/trunk/x86/packages/Packages.gz.
Updated list of available packages in /opt/opkg-lists/snapshots.
root@CS-Internet-App:~# opkg install libgcc
Multiple packages (libgcc and libgcc) providing same name marked HOLD or PREFER. Using latest.
Installing libgcc (linaro-79) to root...
Collected errors:
 * opkg_download_pkg: Package libgcc is not available from any configured src.
 * opkg_install_pkg: Failed to download libgcc. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package libgcc.
root@CS-Internet-App:~#
}}}[[BR]]
in /lib dir I find only libgcc_s.so.1 lib.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:2 Changed 6 years ago by jow

This package is flagged as essential and hold, you're not allowed to upgrade it as it may (and likely will) break the entire system.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.