Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#10049 closed defect (worksforme)

DIR-601: "mtd erase nvram" in OpenWRT bricks router

Reported by: W.I.C Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: other Version: Trunk
Keywords: Cc:

Description

Hopefully someone here can help me out.

I have a Dlink DIR-600-A1 router, and I was successfully running one of the latest trunk versions of Openwrt Attitude Adjustment.

I went a bit wild updating packages on my router, and was left with nearly no free space, so i decided that I wanted to "reset to defaults" to gain back the space that was lost.

After a google search, I foolishly ran "mtd erase nvram" and rebooted the router only to discover that it will not boot anymore.

I then accessed the Dlink Emergency Room bootloader and flashed OpenWrt back to the router. The firmware flash completed, however the router still refuses not boot. The power light remains orange, and the router power cycles every 30 seconds, non-stop.

I tried flashing the original stock firmware via the Dlink Emergency Room, and the router behaves in the same way...firmware is flashed, but the router refuses to boot.

Oddly enough, I was able to flash DD-WRT to the router, and the router boots (works) !?!?

I'm assuming that the "mtd erase nvram" command removed certain boot variables that are needed for OpenWrt and the stock Dlink fimrware to boot, but not those that affect DD-WRT.

Do any of the OpenWrt and Dlink router gurus out there know of a way that I can get OpenWrt or the stock firmware working on the router again?

Flashing the firmware back to the device is not enough to get OpenWrt running on it again, but maybe there's something I can do/type from DD-WRT that would make it work? I feel like an idiot for running "mtd erase nvram" in OpenWrt :(

Thanks in advance!

Update:

I have just noticed that DD-WRT no longer displays the genuine MAC addresses:

LAN MAC 00:11:22:33:44:66
WAN MAC 00:11:22:33:44:55

Am I screwed?

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by W.I.C

As long as you are running OpenWrt on your DIR-601/600-A1 you can help me resolve this issue. All I need is a copy of the NVRAM partition on your router in order to determine what is and is not missing. You can obtain this by running the below command on the router via telnet or SSH:

dd if=/dev/mtdblock/1 of=/tmp/nvram-dir-601.bin

Uploading it as an attachment to this ticket would be a life saver..well a router saver!

I can't offer much in return, but I can share the steps involved in order to get Asterisk to work on the DIR-601!

I know that one of you guys/gals will be willing to help me, so thanks in advance!

comment:2 Changed 6 years ago by anonymous

A fellow DIR-601 user supplied me with a copy of his uboot and nvram partitions. A dd-wrt and open-wrt guru, then injected my original mac addresses into the nvram partition, allowing me to write wrote both partitions (combined) to the RedBoot mtd partition of DD-WRT.

Problem solved: The router can now boot OpenWrt and the stock firmware.

The ticket can be closed.

comment:3 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.