Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10037 closed defect (fixed)

ar71xx : interrupts errors on NanostationM5

Reported by: ffrrrr@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: ar71xx interrupts errors Cc:

Description

I get a lot of interrupts errors on a Ubiquiti NanostationM5.

/proc/interrupts just after booting (r28139) looks like:

BusyBox v1.18.5 (2011-08-21 22:32:40 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r28139) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# cat /proc/interrupts 
           CPU0       
  4:        441      MIPS  eth0
  5:          0      MIPS  eth1
  6:          0      MIPS  cascade [AR71XX MISC]
  7:       5105      MIPS  timer
 10:          0  AR71XX MISC  cascade [AR71XX GPIO]
 11:         34  AR71XX MISC  serial
 72:        845  AR724X PCI   ath9k
ERR:       6425
root@OpenWrt:~# uptime
 16:52:58 up 0 min, load average: 0.30, 0.10, 0.03

dmesg :

Linux version 2.6.39.4 (frederic@iter) (gcc version 4.5.4 20110808 (prerelease) (Linaro GCC 4.5-2011.08) ) #6 Thu Sep 1 17:48:44 CEST 2011
prom: fw_arg0=00000006, fw_arg1=a1f7bfb0, fw_arg2=a1f7c460, fw_arg3=00000000
MyLoader: sysp=ff00ff00, boardp=ff00ff08, parts=f00ff00f
bootconsole [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
SoC: Atheros AR7240 rev 2
Clocks: CPU:390.000MHz, DDR:390.000MHz, AHB:195.000MHz, Ref:5.000MHz
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 802ba470, node_mem_map 81000000
  Normal zone: 64 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 8128 pages, LIFO batch:0
pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
pcpu-alloc: [0] 0 
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line:  board=UBNT-NM console=ttyS0,115200 mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1024k(kernel),6528k(rootfs),256k(cfg)ro,64k(EEPROM)ro,7552k@0x50000(firmware) rootfstype=squashfs,jffs2 noinitrd
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 29364k/32768k available (2018k kernel code, 3404k reserved, 391k data, 176k init, 0k highmem)
SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
NR_IRQS:80
Calibrating delay loop... 259.27 BogoMIPS (lpj=1296384)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
NET: Registered protocol family 16
MIPS: machine is Ubiquiti Nanostation M
registering PCI controller with io_map_base unset
bio: create slab <bio-0> at 0
pci 0000:00:00.0: [168c:ff1c] type 0 class 0x000200
pci 0000:00:00.0: fixup device configuration
pci 0000:00:00.0: reg 10: [mem 0x00000000-0x0000ffff 64bit]
pci 0000:00:00.0: supports D1
pci 0000:00:00.0: PME# supported from D0 D1 D3hot
pci 0000:00:00.0: PME# disabled
pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bit]
pci 0000:00:00.0: BAR 0: set to [mem 0x10000000-0x1000ffff 64bit] (PCI address [0x10000000-0x1000ffff])
PCI: mapping irq 72 to pin1@0000:00:00.0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
PCI: CLS 0 bytes, default 32
squashfs: version 4.0 (2009/01/31) Phillip Lougher
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console [ttyS0] enabled, bootconsole disabled
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: found w25x64, expected m25p80
m25p80 spi0.0: w25x64 (8192 Kbytes)
7 cmdlinepart partitions found on MTD device spi0.0
Creating 7 MTD partitions on "spi0.0":
0x000000000000-0x000000040000 : "u-boot"
0x000000040000-0x000000050000 : "u-boot-env"
0x000000050000-0x000000150000 : "kernel"
0x000000150000-0x0000007b0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=35B000, len=455000 
0x00000035b000-0x0000007b0000 : "rootfs_data"
0x0000007b0000-0x0000007f0000 : "cfg"
0x0000007f0000-0x000000800000 : "EEPROM"
0x000000050000-0x0000007b0000 : "firmware"
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: connected to PHY at ag71xx-mdio:04 [uid=004dd041, driver=Generic PHY]
eth1: Atheros AG71xx at 0xba000000, irq 5
eth1: Found an AR7240 built-in switch
Atheros AR71xx hardware watchdog driver version 0.1.0
ar71xx-wdt: timeout=15 secs (max=22)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 176k freed
input: gpio-keys-polled as /devices/platform/gpio-keys-polled/input/input0
Button Hotplug driver version 0.4.1
Registered led device: ubnt:red:link1
Registered led device: ubnt:orange:link2
Registered led device: ubnt:green:link3
Registered led device: ubnt:green:link4
eth0: link up (100Mbps/Full duplex)
JFFS2 notice: (377) jffs2_build_xattr_subsystem: complete building xattr subsystem, 2 of xdatum (1 unchecked, 1 orphan) and 36 of xref (0 dead, 19 orphan) found.
eth0: link down
NET: Registered protocol family 10
ADDRCONF(NETDEV_UP): eth0: link is not ready
eth0: link up (100Mbps/Full duplex)
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
Compat-wireless backport release: compat-wireless-2011-08-25
Backport based on wireless-testing.git master-2011-08-26
cfg80211: Calling CRDA to update world regulatory domain
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
cfg80211: World regulatory domain updated:
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
PCI: Setting latency timer of device 0000:00:00.0 to 64
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: ath9k-phy0
ieee80211 phy0: Atheros AR9280 Rev:2 mem=0xb0000000, irq=72
cfg80211: Calling CRDA for country: US
PPP generic driver version 2.4.2
IPv6 over IPv4 tunneling driver
ip_tables: (C) 2000-2006 Netfilter Core Team
cfg80211: Regulatory domain changed to country: US
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
NET: Registered protocol family 24
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
nf_conntrack version 0.5.0 (461 buckets, 1844 max)
ip6_tables: (C) 2000-2006 Netfilter Core Team
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: direct probe to 00:15:6d:18:1e:6f (try 1/3)
wlan0: direct probe responded
wlan0: authenticate with 00:15:6d:18:1e:6f (try 1)
wlan0: authenticated
wlan0: associate with 00:15:6d:18:1e:6f (try 1)
wlan0: RX AssocResp from 00:15:6d:18:1e:6f (capab=0x401 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
ar71xx-wdt: enabling watchdog timer

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by zerosigea@…

I'm getting the same on a D-Link DIR-825.

BusyBox v1.18.5 (2011-09-03 11:45:08 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 ATTITUDE ADJUSTMENT (bleeding edge, r28151) ----------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt:~# uptime
 16:10:31 up 12:03, load average: 0.08, 0.06, 0.05
root@OpenWrt:~# cat /proc/interrupts
           CPU0
  3:         15      MIPS  ehci_hcd:usb1
  4:     450333      MIPS  eth0
  5:    8134688      MIPS  eth1
  6:          0      MIPS  cascade [AR71XX MISC]
  7:    4357912      MIPS  timer
 10:          0  AR71XX MISC  cascade [AR71XX GPIO]
 11:         17  AR71XX MISC  serial
 14:          0  AR71XX MISC  ohci_hcd:usb2
 72:   20828341  AR71XX PCI   ath9k
 73:   12646710  AR71XX PCI   ath9k
ERR:   46418016
root@OpenWrt:~#

I had a USB flash drive connected to the unit, and thought that it might have been the cause, so I removed it. However, the error interrupts still increased. Another thing I have noticed is that the total amount of interrupts over all the devices equals the amount of error interrupts. Double checked the OP and it's the same thing for him. I'm guessing that this is just a bug in the ar71xx's interrupt handler that's marking every interrupt as ERR even though they've been handled correctly. Or that there is there a spurious interrupt generated for every valid interrupt.

comment:2 Changed 6 years ago by Alexey Loukianov <mooroon2@…>

Same here on DIR-615 E4 box (AR7240 rev 2 CPU/AR9287 wifi phy):

root@OpenWrt:/# cat /proc/interrupts

CPU0

3: 0 MIPS ohci_hcd:usb1
4: 0 MIPS eth1
5: 4417 MIPS eth0
6: 0 MIPS cascade [AR71XX MISC]
7: 206448 MIPS timer

10: 0 AR71XX MISC cascade [AR71XX GPIO]
11: 34 AR71XX MISC serial
72: 296516 AR724X PCI ath9k

ERR: 507415
root@OpenWrt:/# cat /proc/interrupts

CPU0

3: 0 MIPS ohci_hcd:usb1
4: 0 MIPS eth1
5: 4429 MIPS eth0
6: 0 MIPS cascade [AR71XX MISC]
7: 206482 MIPS timer

10: 0 AR71XX MISC cascade [AR71XX GPIO]
11: 34 AR71XX MISC serial
72: 296566 AR724X PCI ath9k

ERR: 507511

comment:3 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

this was a purely cosmetic bug, normal interrupts were reported as spurious interrupts.

fixed in r28182

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.