Modify

Opened 6 years ago

Closed 6 years ago

Last modified 18 months ago

#10025 closed defect (worksforme)

Deauthenticated due to local deauth request on a tp-link wa901nd v2 running wpa2-psk

Reported by: Jonathan Bennett <jbscience87@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Sorry for flooding you guys (especially nbd) with wireless problems today. I've finally gotten time to really dig into the wireless issues I've been having, and identified several distinct problems.

I'm currently on r28122 on this AP. When running wpa2-psk, clients can connect, but I get "Deauthenticated due to local deauth request" every 10 minutes, precisely. It seems that it happens for every group rekey.

One of the clients is a Linux laptop (running Fedora 15, very recent kernel, fully updated, etc). To get a better idea of what was going on, I turned off networkmanager, and connected to the wireless from a terminal, using wpa_supplicant. I'll attach a sample of that log, but here's the line that jumps out at me:

WPA: AES unwrap failed - could not decrypt EAPOL-Key key data

I'm connected to the router via a hard line, and watching its log via telnet.

A moment after the laptop complains that it cannot decrypt the EAPOL data, the router reports the deauth.

I've also restarted hostapd manually to watch its output, and this backs up my hunch. I can see hostapd send the group key handshake, and then timeout because it doesn't get a response. At the same time, the laptop registers receiving the packet, but drops it because it can't decrypt it. The router tries to rekey several times, but then just deauths the client because it keeps timing out.

I don't know why the rekey message cannot be decrypted by the laptop, but that does seem to be the root cause of the deauth errors I've seen.

I'll be happy to provide more info if requested, and I'll attach the pertinent hostapd and wpa_supplicant logs to this ticket.

Attachments (5)

hostapd_rekey.log (3.9 KB) - added by Jonathan Bennett <jbscience87@…> 6 years ago.
Hostapd log of rekey failure
wpa_supplicant_rekey.log (6.0 KB) - added by Jonathan Bennett <jbscience87@…> 6 years ago.
WPA_Supplicant output of rekey attempt
log-deauth-eapol (2.4 KB) - added by philchetcuti 6 years ago.
output from logread
hostapd.log (64.5 KB) - added by philchetcuti 6 years ago.
hostapd.log
logread-switch-wl-b43 (21.2 KB) - added by philchetcuti 6 years ago.
logread comparing wl and b43 drivers r28172

Download all attachments as: .zip

Change History (34)

Changed 6 years ago by Jonathan Bennett <jbscience87@…>

Hostapd log of rekey failure

Changed 6 years ago by Jonathan Bennett <jbscience87@…>

WPA_Supplicant output of rekey attempt

comment:1 follow-up: Changed 6 years ago by nbd

What kind of wifi card are you using in your laptop? Do you have any other client available for testing? I'm running the latest code at home, and I can't reproduce that issue, even with an extremely short rekey interval.

comment:2 in reply to: ↑ 1 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

Replying to nbd:

What kind of wifi card are you using in your laptop? Do you have any other client available for testing? I'm running the latest code at home, and I can't reproduce that issue, even with an extremely short rekey interval.

Laptop wireless:

01:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g LP-PHY (rev 01)

I'm using the broadcom-wl driver.

I also have a Samsung Galaxy S Android (CM7) phone that disconnects in the same way. (I haven't tried to run wpa_supplicant by hand, but the router logs are the same for both devices.)

I have an older linux laptop that I can try, and I can boot this laptop into Windows 7 and try it there. Will report back with those results.

comment:3 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

Here are 3 different devices, all showing said behavior:

root@OpenWrt:/# logread -f
Mar 27 05:26:28 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 IEEE 802.11: authenticated
Mar 27 05:26:28 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 IEEE 802.11: associated (aid 2)
Mar 27 05:26:28 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 WPA: pairwise key handshake completed (RSN)
Mar 27 05:27:44 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 IEEE 802.11: authenticated
Mar 27 05:27:44 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 IEEE 802.11: associated (aid 3)
Mar 27 05:27:44 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 WPA: pairwise key handshake completed (RSN)
Mar 27 05:32:11 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 IEEE 802.11: deauthenticated due to local deauth request
Mar 27 05:32:11 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 IEEE 802.11: deauthenticated due to local deauth request
Mar 27 05:32:11 OpenWrt daemon.info hostapd: wlan0: STA 5c:da:d4:87:90:8e IEEE 802.11: deauthenticated due to local deauth request
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 IEEE 802.11: authenticated
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 IEEE 802.11: associated (aid 1)
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA e0:b9:a5:30:b9:02 WPA: pairwise key handshake completed (RSN)
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 IEEE 802.11: authenticated
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 IEEE 802.11: associated (aid 2)
Mar 27 05:32:13 OpenWrt daemon.info hostapd: wlan0: STA 00:15:af:b5:c9:33 WPA: pairwise key handshake completed (RSN)

It's a phone, an Asus Eee running Fedora 14 or so, and the laptop booted into Win7.
The Eee is using the Atheros 5001.

Changed 6 years ago by philchetcuti

output from logread

comment:4 Changed 6 years ago by philchetcuti

I've added to your log files, TPLink wr1043nd revision 28135

That was just a snippet of the log, the pattern continues to repeat itself with small variances in the amount of deauths before the eapol error.

comment:5 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

philchetcuti,

Yours is actually a bit different error. To get a deeper look at what's going on in the router, ssh into it and run this command.

killall -9 hostapd; hostapd -dd /var/run/hostapd-phy0.conf | grep -v randomness

Copy the output when you try to connect and attach the file. I'll try to take a look at what's going on.

comment:6 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

nbd, an update on this issue. I realized that my TL-wr841nd v5 was not having the deauth issue at r28108. It was running wpa2-psk and the group rekeys were working properly. I compiled and updated it to 28122, and the group rekey failed as noted above.

I used svn to revert my source back to r28108, did a make clean and a make, and flashed that image to the wr841. Group rekey works once again.

I don't have time to bisect the issue further right now. The only change to hostapd is your patch to not drop eapol packets. I've looked at that patch, and I can't see any way that it would explain the issues with group rekeys.

As to why it's not reproducible on your equipment...
What router are you running on? Is it an ar71xx based device?
Are you sure you don't have any patches in your source tree that aren't in trunk?

As I have time I'll continue to dig into the issue. Thanks for your continuing help.

~Jonathan Bennett

Changed 6 years ago by philchetcuti

hostapd.log

comment:7 Changed 6 years ago by philchetcuti

Jonathan,
I've attached the log as requested. I simply let the command run until my system had disconnected and reconnected 3 times.

By the way, I notice in the post above that you refer to r28108. That is also the most recent revision that I can run successfully.

comment:8 Changed 6 years ago by nbd

Jonathan, can you try to isolate whether the issue is with the hostapd update or the mac80211 update?
I'm doing most of of my testing on ar71xx and haven't been able to reproduce any issues (without any patches on top of trunk).

comment:9 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

@PhilChetCuti:

OK, thanks for this additional logfile. In comparing the two logs you've sent, I can draw a couple conclusions.

First, the router thinks the wpa handshake is succeeding. The client is successfully requesting an ip address, so they really do have a successful connection, but only for a moment.

Second, the client then disassociates very quickly after connection. There isn't a glaring reason for the deauth in either log.

Is this a Linux laptop? if so, it would be nice to run wpa supplicant by hand and see its output. (guide: http://linux.byexamples.com/archives/148/setting-wpa-supplicant-for-wifi-access/ don't use the '-B' option, we don't want it to run as a deamon, we want to watch its output.)

Are you using WPA or WPA2?

~Jonathan Bennett

comment:10 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

@nbd: Well... I'm about 500 miles from home for the next week and a half. I have ssh access back into my network, though, and the printer there should automatically connect to the wireless. I just get to experience the fun of flashing the running router and hoping it comes back up correctly afterwards. I'm compiling on my desktop there, and will let you know how it goes after I flash.

comment:11 Changed 6 years ago by philchetcuti

@Jonathan Bennett

Yes, the laptop is linux, I'll be able to get you that output. I am running WPA2.

Sorry for being remiss but I should have mentioned that I am running an ap/sta configuration here, not sure if that might change your diagnostic direction.

I'm going to reflash the router with r28135 and then run some tests with just an ap config and then with ap/sta config to see if the problem exists with both. Should have the results within a few hours.

comment:12 Changed 6 years ago by nbd

by the way, i fixed a crash/hang issue in r28139

comment:13 Changed 6 years ago by philchetcuti

My previous problem was with disconnects. Once I had established a connection it would work for awhile then at some point it would begin a cycle of disconnecting/reconnecting every minute non stop. It would never reconnect successfully again. The length of time before this behaviour began varied, sometimes I would be okay for 10 or 15 minutes, but if I did something like stream radio, the behaviour began much quicker, like 3 minutes or less.

Today I was going to retest with Jonathon's instructions. But instead of reflashing with r28135 I went up to r28139.

Sorry Jonathon, but I won't be able to give you a report because I've been running successfully for 2 hours and 45 minutes without a single disconnect. And I've had streaming radio on the whole time.

I do see something in the hostapd log that is different than anything I saw in my previous tests. I never saw a REKEY event before. I've included a snippet from the new log that includes that event just for the sake of completeness.

wlan0: WPA rekeying GTK
WPA: group state machine entering state SETKEYS (VLAN-ID 0)
GTK - hexdump(len=16): [REMOVED]
WPA: 00:22:69:5c:4a:c3 WPA_PTK_GROUP entering state REKEYNEGOTIATING
wlan0: STA 00:22:69:5c:4a:c3 WPA: sending 1/2 msg of Group Key Handshake
WPA: Send EAPOL(version=2 secure=1 mic=1 ack=1 install=0 pairwise=0 kde_len=24 keyidx=2 encr=1)
Plaintext EAPOL-Key Key Data - hexdump(len=32): [REMOVED]
WPA: Use EAPOL-Key timeout of 1000 ms (retry counter 1)
wpa_group_setkeys: GKeyDoneStations=1
IEEE 802.1X: 99 bytes from 00:22:69:5c:4a:c3

IEEE 802.1X: version=1 type=3 length=95

WPA: Received Key Nonce - hexdump(len=32): 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
WPA: Received Replay Counter - hexdump(len=8): 00 00 00 00 00 00 00 09
wlan0: STA 00:22:69:5c:4a:c3 WPA: received EAPOL-Key frame (2/2 Group)
WPA: 00:22:69:5c:4a:c3 WPA_PTK_GROUP entering state REKEYESTABLISHED
wlan0: STA 00:22:69:5c:4a:c3 WPA: group key handshake completed (RSN)
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
wpa_driver_nl80211_set_key: ifindex=6 alg=3 addr=0x44ea1c key_idx=2 set_tx=1 seq_len=0 key_len=16

broadcast key

WPA: 00:22:69:5c:4a:c3 WPA_PTK_GROUP entering state IDLE
wlan0: Station 00:22:69:5c:4a:c3 has been active 0s ago

comment:14 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

nbd: I've flashed r28110 to the home router, and the printer is successfully doing group rekeys. When I tried 28112, it had to re-associate every 10 minutes as I described earlier.

I'll flash two more revisions, just to be sure. I'll compile r28139 and test it, since phil reported success with it. I suspect I'll still get disconnects, but I will try it. If that is the case, I'll remove 570-eapol-key-type and recompile. I suspect that will work correctly for me. Will report back when I can get that finished.

~Jonathan Bennett

comment:15 Changed 6 years ago by philchetcuti

@Jonathan

Just to give you more confidence, I'm still up and running without a single disconnect 5 hours in now.

comment:16 Changed 6 years ago by Jonathan Bennett <jbscience87@…>

nbd: I've updated to the most recent trunk, and group rekey does not work. I then removed the eapol patch and group rekey completed successfully.

I don't know why the patch caused the problem, but removing it did correct the group rekey problem.

comment:17 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Dropped the patch, thanks for testing.

comment:18 Changed 6 years ago by sam.right@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

TP-Link wr841nd-v5 running at r28150 and I believe its a lot worse than before in regarding wireless dropout. I can see a lot of deauthenticated due to local deauth request for the last 2 days. Restart will normally solve it but it deteoriates over the time

Sep  3 12:47:02 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 15:47:02 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 15:47:02 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 16:47:02 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 16:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:23:07 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:23:18 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:24:08 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:24:32 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:24:49 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:24:54 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:25:04 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:25:12 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:25:26 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:25:51 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:26:16 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:26:38 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 17:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 18:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 19:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 20:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 21:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 22:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 22:47:02 firewall hostapd: wlan0: STA ac:81:12:13:1c:23 IEEE 802.11: deauthenticated due to local deauth request
Sep  3 23:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 00:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 01:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 02:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 03:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 04:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 05:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 06:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 07:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 07:48:47 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 07:48:51 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 07:48:51 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:52:04 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:52:09 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:52:15 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:52:19 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 08:52:23 firewall hostapd: wlan0: STA 00:16:cf:50:9a:bf IEEE 802.11: deauthenticated due to local deauth request
Sep  4 09:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 10:47:02 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 11:23:14 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 11:23:18 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 11:26:00 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 11:26:03 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 12:15:42 firewall hostapd: wlan0: STA 00:0f:b5:0e:7f:e2 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 12:15:43 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 13:15:42 firewall hostapd: wlan0: STA 00:09:5b:f8:fa:d8 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 13:15:42 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 13:15:45 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 13:27:41 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 13:27:44 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  4 18:15:42 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  5 07:34:10 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  5 07:34:13 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  5 07:50:19 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request
Sep  5 07:50:23 firewall hostapd: wlan0: STA 00:1d:fe:e9:0c:63 IEEE 802.11: deauthenticated due to local deauth request

comment:19 Changed 6 years ago by nbd

try r28169

comment:20 Changed 6 years ago by sam.right@…

@nbd

I always builds the backfire branch. I have built a new firmware based on r28170 which is essentially the same thing as r28169. Do you recommend to use trunk instead of backfire branch?

comment:21 Changed 6 years ago by nbd

backfire is fine, the mac80211 package is in sync with trunk at the moment

Changed 6 years ago by philchetcuti

logread comparing wl and b43 drivers r28172

comment:22 Changed 6 years ago by philchetcuti

I'm also having dropouts again r28172
nbd, I noticed earlier that you had asked jonathan which driver he was using, so I gave you a logread of both wl and b43 (its commented to show you when I switched from one to the other)
Currently wl is very faulty, very very slow to connect, eventually it drops and will not connect again.
b43 is currently fairly stable, while wicd tells me the connection was lost sometimes, my ssh session does not drop when wicd tells me this.

comment:23 Changed 6 years ago by sam.right@…

I changed the wifi mode from 11ng to 11g and commented out all the 11n features like diversity, htmode and ht_capab and now the wireless seems much stable now.

I have one or two 11g client and 3 11n clients.

comment:25 Changed 6 years ago by nbd

please try r28203, it should improve stability

comment:26 Changed 6 years ago by sam.right@…

@Nilfred
You were right. My home network has been subjected to wifi deauthentication attack since 9th August.

I have created a new ticket #10109 so hopefully someone could implement it.

comment:27 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:28 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:29 Changed 18 months ago by anonymous

I have the same problem with 1043nd v3 and 15.05.1
Fixes with option wpa_group_rekey '0'
More info:
http://www.zron.fr/tools/projets/freetools/Linux/openwrt/wifi%20disconnects.txt

https://forum.openwrt.org/viewtopic.php?pid=215126

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.