Modify

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#10000 closed defect (worksforme)

WZR-HP-G300NH Cannot Set TXPOWER above 21

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Tried to issue command to set txpower to 27 but retains 21
OpenWrt Firmware Attitude Adjustment (r28078) / LuCI Trunk trunk+svn7369

root@OpenWrt:~# iw list
Wiphy phy0

Band 1:

Capabilities: 0x104e

HT20/HT40
SM Power Save disabled
RX HT40 SGI
No RX STBC
Max AMSDU length: 3839 bytes
DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-15
Frequencies:

  • 2412 MHz [1] (27.0 dBm)
  • 2417 MHz [2] (27.0 dBm)
  • 2422 MHz [3] (27.0 dBm)
  • 2427 MHz [4] (27.0 dBm)
  • 2432 MHz [5] (27.0 dBm)
  • 2437 MHz [6] (27.0 dBm)
  • 2442 MHz [7] (27.0 dBm)
  • 2447 MHz [8] (27.0 dBm)
  • 2452 MHz [9] (27.0 dBm)
  • 2457 MHz [10] (27.0 dBm)
  • 2462 MHz [11] (27.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 2257 bytes
Coverage class: 0 (up to 0m)
Available Antennas: TX 0 RX 0
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • WDS
  • monitor
  • mesh point
  • P2P-client
  • P2P-GO

Supported commands:

  • new_interface
  • set_interface
  • new_key
  • new_beacon
  • new_station
  • new_mpath
  • set_mesh_params
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • join_mesh
  • remain_on_channel
  • set_tx_bitrate_mask
  • action
  • frame_wait_cancel
  • set_wiphy_netns
  • set_channel
  • set_wds_peer
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0

Supported RX frame types:

  • IBSS: 0x00d0
  • managed: 0x0040 0x00d0
  • AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • mesh point: 0x00b0 0x00c0 0x00d0
  • P2P-client: 0x0040 0x00d0
  • P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0

root@OpenWrt:~# cat /etc/config/wireless

config 'wifi-device' 'radio0'

option 'type' 'mac80211'
option 'macaddr' '00:24:a5:d8:5a:37'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'DSSS_CCK-40'
option 'channel' '9'
option 'txpower' '27'
option 'country' 'US'
option 'disabled' '0'
option 'hwmode' '11g'

config 'wifi-iface'

option 'device' 'radio0'
option 'network' 'lan'
option 'mode' 'ap'
option 'ssid' 'stayOut'
option 'encryption' 'psk2'
option 'key' 'xxx'

root@OpenWrt:~# iwconfig wlan0
wlan0 IEEE 802.11bgn Mode:Master Frequency:2.452 GHz Tx-Power=21 dBm

RTS thr:off Fragment thr:off
Power Management:on

root@OpenWrt:~# iwlist txpower
lo no transmit-power information.

eth0 no transmit-power information.

eth1 no transmit-power information.

eth0.1 no transmit-power information.

ifb0 no transmit-power information.

ifb1 no transmit-power information.

br-lan no transmit-power information.

wlan0 unknown transmit-power information.

Current Tx-Power=21 dBm (125 mW)

mon.wlan0 unknown transmit-power information.

Current Tx-Power=21 dBm (125 mW)

Attachments (0)

Change History (12)

comment:1 Changed 6 years ago by anonymous

also seeing this on latest backfire. With rspro ath9k its stuck at 23dbm. Please fix.
-matt

comment:2 Changed 6 years ago by anonymous

mine at 17 dbm

comment:3 Changed 6 years ago by anonymous

to clarify, the g300nh is stuck at 21dbm. a mikrotik r52n in the rspro is stuck at 23dbm. both with country 'US'.
-matt

comment:4 Changed 6 years ago by blindbox

I can confirm this to be true on WR1043ND. A few revisions ago (trunk), it was stuck at 24dBm. Now it's stuck at 23dBm. Same country, US. Any other country that's below 23/24 dBm follows the limit properly.

comment:5 Changed 6 years ago by nbd

what are the reported tx power limits with r28253?

comment:6 Changed 6 years ago by blindbox

No change. Issue still persists in r28253.

This is on TL-WR1043ND.

root@OpenWrt:~# iwlist txpower
lo        no transmit-power information.

eth0      no transmit-power information.

eth0.1    no transmit-power information.

eth0.500  no transmit-power information.

br-lan    no transmit-power information.

wlan0     unknown transmit-power information.

          Current Tx-Power=23 dBm       (199 mW)

mon.wlan0  unknown transmit-power information.

          Current Tx-Power=23 dBm       (199 mW)

pppoe-wan  no transmit-power information.

ifb0      no transmit-power information.

comment:7 Changed 6 years ago by blindbox

Oops hang on. Remants of previous compile seems to exist.

opkg list says,

kmod-ath9k - 2.6.39.4+2011-09-14-1

Not sure if it matters, but I'm recompiling with make dirclean.

comment:8 Changed 6 years ago by blindbox

I've recompiled my openwrt.

Two posts above this one, still applies.

comment:9 Changed 6 years ago by anonymous

still broken @28262, using HT20 in AP:

root@OpenWrt:~# iwconfig wlan0 txpower 17
root@OpenWrt:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

br-lan    no wireless extensions.

wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.412 GHz  Tx-Power=17 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:on
          
mon.wlan0  IEEE 802.11bgn  Mode:Monitor  Tx-Power=17 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:on
          
root@OpenWrt:~# iwconfig wlan0 txpower 23
root@OpenWrt:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

br-lan    no wireless extensions.

wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.412 GHz  Tx-Power=21 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:on
          
mon.wlan0  IEEE 802.11bgn  Mode:Monitor  Tx-Power=21 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:on

thanks,
-matt

comment:10 Changed 6 years ago by Ownatik

Same issue on r28291, channel 11, 40mhz, CA, WZR-HP-G300NH.

comment:11 Changed 6 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

If you're seeing too low tx power with any recent version, that's likely your eeprom being calibrated for those specific limits. It may be that the device is transmitting at a higher power than what it shows because it may have been calibrated with a tx power offset. If that is the case, then there's no way for the driver to know that or figure it out, hence it's not a software bug.

I've seen multiple devices from Buffalo with the same model name showing different tx power limits, and from reading and interpreting the EEPROM data, the driver does the right thing.

I've looked at lots of EEPROM data and so far I see no indication that the driver is interpreting the EEPROM wrong, so if you feel that your tx power is lower than you think it should be, please do *NOT* reopen tx power related tickets unless you have any kind of evidence that it's a software issue.

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.