Changeset 48934


Ignore:
Timestamp:
2016-03-05T22:07:18+01:00 (2 years ago)
Author:
nbd
Message:

prereq: stop relying on man pages and grep for --recursive on the git-submodule script directly (fixes #21968)

Signed-off-by: Felix Fietkau <nbd@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/prereq-build.mk

    r48927 r48934  
    156156 
    157157$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \ 
    158         MANPAGER=cat git submodule --help 2>&1 | grep -q -- --recursive)) 
     158        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule)) 
    159159 
    160160$(eval $(call SetupHostCommand,file,Please install the 'file' package, \ 
Note: See TracChangeset for help on using the changeset viewer.