Changeset 48830


Ignore:
Timestamp:
2016-02-29T21:12:25+01:00 (2 years ago)
Author:
nbd
Message:

buildroot: improve git submodule handling for packages

Move the --recursive switch from git clone to git submodule
so that submodules are cloned for upstream branches where the
PKG_SOURCE_VERSION commit-ish has a different .gitmodules
configuration than the repository default.

This is, for example, required when the master branch for a source
package does not use submodules, but its topic branch for OpenWRT
does.

This changes the buildroot dependency from git-1.6.2 to git 1.7.12.2,
which was released September 2012.

Signed-off-by: Darik Horn <dajhorn@…>
Signed-off-by: Karl Palsson <karlp@…>

Location:
trunk/include
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/download.mk

    r48733 r48830  
    9191                rm -rf $(SUBDIR) && \ 
    9292                [ \! -d $(SUBDIR) ] && \ 
    93                 git clone $(URL) $(SUBDIR) --recursive && \ 
    94                 (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \ 
     93                git clone $(URL) $(SUBDIR) && \ 
     94                (cd $(SUBDIR) && git checkout $(VERSION) && \ 
     95                git submodule update --init --recursive) && \ 
    9596                echo "Packing checkout..." && \ 
    9697                rm -rf $(SUBDIR)/.git && \ 
  • trunk/include/prereq-build.mk

    r48267 r48830  
    155155        svn --version | grep Subversion)) 
    156156 
    157 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \ 
    158         git clone 2>&1 | grep -- --recursive)) 
     157$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \ 
     158        git submodule update --help 2>&1 | grep -- --recursive)) 
    159159 
    160160$(eval $(call SetupHostCommand,file,Please install the 'file' package, \ 
Note: See TracChangeset for help on using the changeset viewer.