Changeset 42592


Ignore:
Timestamp:
2014-09-17T13:01:24+02:00 (3 years ago)
Author:
blogic
Message:

sdk: predefine kernel version magic

Kernel modules which are built using the SDK do not have access
to the .vermagic file in the Linux build dir, therefore the
generated .ipk metadata depends on kernel versions like
'3.10.49-1-unknown' which are not satisfiable by the kernel
meta package in the image.

Fix this problem by substituting 'unknown' with the current
version magic in include/kernel.mk when packing the SDK.

Signed-off-by: Jo-Philipp Wich <jow@…>

Backport of r42590

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/barrier_breaker/target/sdk/Makefile

    r42398 r42592  
    109109                >> $(SDK_BUILD_DIR)/feeds.conf.default 
    110110        $(SED) 's,^# REVISION:=.*,REVISION:=$(REVISION),g' $(SDK_BUILD_DIR)/include/version.mk 
     111        $(SED) '/LINUX_VERMAGIC:=/ { s,unknown,$(LINUX_VERMAGIC),g }' $(SDK_BUILD_DIR)/include/kernel.mk 
    111112        find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf 
    112113        find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf 
Note: See TracChangeset for help on using the changeset viewer.