Changeset 36371


Ignore:
Timestamp:
2013-04-21T18:34:09+02:00 (5 years ago)
Author:
luka
Message:

[packages] squashfs-tools: fix recursive dependency

Location:
packages/utils/squashfs-tools
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • packages/utils/squashfs-tools/Config.in

    r36317 r36371  
    1 if PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs 
    2  
    31config SQUASHFS_TOOLS_LZO_SUPPORT 
     2        depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs 
    43        bool "Enable LZO support" 
     4        select PACKAGE_liblzo 
    55        default y 
    66 
    77config SQUASHFS_TOOLS_XZ_SUPPORT 
     8        depends on PACKAGE_squashfs-tools-mksquashfs || PACKAGE_squashfs-tools-unsquashfs 
    89        bool "Enable XZ support" 
     10        select PACKAGE_liblzma 
    911        default y 
    10  
    11 endif 
  • packages/utils/squashfs-tools/Makefile

    r36317 r36371  
    1010PKG_NAME:=squashfs-tools 
    1111PKG_VERSION:=4.2 
    12 PKG_RELEASE:=2 
     12PKG_RELEASE:=3 
    1313 
    1414PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz 
     
    2727  CATEGORY:=Utilities 
    2828  TITLE:=squashfs-tools 
    29   DEPENDS += +libpthread +zlib \ 
    30         +SQUASHFS_TOOLS_LZO_SUPPORT:liblzo \ 
    31         +SQUASHFS_TOOLS_XZ_SUPPORT:liblzma 
     29  DEPENDS += +libpthread +zlib 
    3230endef 
    3331 
Note: See TracChangeset for help on using the changeset viewer.