Changeset 36356


Ignore:
Timestamp:
2013-04-18T14:04:48+02:00 (5 years ago)
Author:
nbd
Message:

toolchain: get rid of uclibc version kconfig symbol overloading

Location:
trunk/toolchain/uClibc
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/toolchain/uClibc/Config.in

    r31740 r36356  
    44        prompt "uClibc Version" 
    55        depends on TOOLCHAINOPTS && USE_UCLIBC 
    6         default UCLIBC_VERSION_0_9_33 
     6        default UCLIBC_USE_VERSION_0_9_33 
    77        help 
    88          Select the version of uClibc you wish to use. 
    99 
    10         config UCLIBC_VERSION_0_9_33 
     10        config UCLIBC_USE_VERSION_0_9_33 
     11                select UCLIBC_VERSION_0_9_33 
    1112                bool "uClibc 0.9.33.2" 
    1213 
    1314endchoice 
    14  
    1515 
    1616# Debug version. 
  • trunk/toolchain/uClibc/Config.version

    r31740 r36356  
    55        default "0.9.33.2" 
    66 
    7 if !TOOLCHAINOPTS 
    8  
    9         config UCLIBC_VERSION_0_9_33 
    10                 default y if USE_UCLIBC 
    11                 bool 
    12  
    13 endif 
     7config UCLIBC_VERSION_0_9_33 
     8        default y if !TOOLCHAINOPTS && USE_UCLIBC 
     9        bool 
Note: See TracChangeset for help on using the changeset viewer.