Changeset 36266


Ignore:
Timestamp:
2013-04-08T00:05:41+02:00 (5 years ago)
Author:
nbd
Message:

ath9k_htc: accept firmware versions newer than 1.3

Signed-off-by: Felix Fietkau <nbd@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/mac80211/patches/300-pending_work.patch

    r36265 r36266  
    10261026 void ieee80211_adjust_monitor_flags(struct ieee80211_sub_if_data *sdata, 
    10271027                                    const int offset); 
     1028--- a/drivers/net/wireless/ath/ath9k/htc_drv_init.c 
     1029+++ b/drivers/net/wireless/ath/ath9k/htc_drv_init.c 
     1030@@ -799,7 +799,7 @@ static int ath9k_init_firmware_version(s 
     1031         * required version. 
     1032         */ 
     1033        if (priv->fw_version_major != MAJOR_VERSION_REQ || 
     1034-           priv->fw_version_minor != MINOR_VERSION_REQ) { 
     1035+           priv->fw_version_minor < MINOR_VERSION_REQ) { 
     1036                dev_err(priv->dev, "ath9k_htc: Please upgrade to FW version %d.%d\n", 
     1037                        MAJOR_VERSION_REQ, MINOR_VERSION_REQ); 
     1038                return -EINVAL; 
Note: See TracChangeset for help on using the changeset viewer.