Changeset 34292


Ignore:
Timestamp:
2012-11-21T21:26:55+01:00 (5 years ago)
Author:
florian
Message:

[toolchain] libthread-db: fix libthread_db.so installation.

libthread_db.so.$(LIBC_SO_VERSION) is only valid for uClibc, (e)glibc just
provides libthread_db.so.1.

Signed-off-by: Florian Fainelli <florian@…>

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/toolchain/Makefile

    r33999 r34292  
    454454        $(INSTALL_DIR) $(1)/lib 
    455455        $(CP) \ 
    456                 $(TOOLCHAIN_DIR)/lib/libthread_db.so.* \ 
     456                $(TOOLCHAIN_DIR)/lib/libthread_db.so.* $(1)/lib 
     457  ifeq ($(USE_UCLIBC),y) 
     458        $(CP) \ 
    457459                $(TOOLCHAIN_DIR)/lib/libthread_db-$(LIBC_SO_VERSION).so \ 
    458460                $(1)/lib/ 
     461  endif 
    459462  endef 
    460463 
Note: See TracChangeset for help on using the changeset viewer.