Changeset 31214


Ignore:
Timestamp:
2012-04-06T14:05:59+02:00 (6 years ago)
Author:
acinonyx
Message:

[include] Add git version check to prerequisite check (#11229)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/include/prereq-build.mk

    r31213 r31214  
    122122)) 
    123123 
    124 $(eval $(call RequireCommand,git, \ 
    125         Please install git (git-core). \ 
     124define Require/git 
     125        git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null 
     126endef 
     127 
     128$(eval $(call Require,git, \ 
     129        Please install git (git-core) v1.6.5 or later. \ 
    126130)) 
    127131 
Note: See TracChangeset for help on using the changeset viewer.