Changeset 28815


Ignore:
Timestamp:
2011-11-07T22:34:32+01:00 (6 years ago)
Author:
juhosg
Message:

ar71xx: change generated Buffalo firmware versions

With version 1.76 the upgrade may fail with newer Buffalo firmwares with
a message like this:
"You can not update the firmware because the firmware version is earlier
than 1.82. Please use 1.82 or later version for firmware update."

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/target/linux/ar71xx/image/Makefile

    r28810 r28815  
    135135                        dd if=$(call sysupname,$(1),$(2)); \ 
    136136                ) > $(call imgname,$(1),$(2))-tftp.bin; \ 
    137                 buffalo-enc -p $(4) -v 1.76 \ 
     137                buffalo-enc -p $(4) -v 1.99 \ 
    138138                        -i $(call sysupname,$(1),$(2)) \ 
    139139                        -o $(KDIR)/$(2).enc; \ 
    140                 buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \ 
     140                buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \ 
    141141                        -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \ 
    142142                        -i $(KDIR)/$(2).enc \ 
     
    153153                        dd if=$(call sysupname,$(1),$(2)); \ 
    154154                ) > $(call imgname,$(1),$(2))-tftp.bin; \ 
    155                 buffalo-enc -p $(5) -v 1.76 \ 
     155                buffalo-enc -p $(5) -v 1.99 \ 
    156156                        -i $(call sysupname,$(1),$(2)) \ 
    157157                        -o $(KDIR)/$(2).enc; \ 
    158                 buffalo-tag -b $(5) -p $(5) -a ath -v 1.76 -m 1.01 -l mlang8 \ 
     158                buffalo-tag -b $(5) -p $(5) -a ath -v 1.99 -m 1.01 -l mlang8 \ 
    159159                        -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \ 
    160160                        -i $(KDIR)/$(2).enc \ 
Note: See TracChangeset for help on using the changeset viewer.