Changeset 27839


Ignore:
Timestamp:
2011-07-30T10:21:58+02:00 (7 years ago)
Author:
mhei
Message:

[packages] php5: fix dependencies for apc and sqlite3 (closes #9368)

When using CONFIGURE_LIBS the php binary itself depends on these libs,
so the opkg depends also reflected this. But in this case it was
required to install those libs even when they were never planned to use.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • packages/lang/php5/Makefile

    r27838 r27839  
    1010PKG_NAME:=php 
    1111PKG_VERSION:=5.3.6 
    12 PKG_RELEASE:=5 
     12PKG_RELEASE:=6 
    1313 
    1414PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 
     
    7575 
    7676  DEPENDS:=+libpcre +zlib \ 
    77            +PHP5_LIBXML:libxml2 \ 
    78            +PACKAGE_php5-mod-apc:librt \ 
    79            +(PACKAGE_php5-mod-sqlite3||PACKAGE_php5-mod-pdo-sqlite):libsqlite3 \ 
    80            +(PACKAGE_php5-mod-sqlite3||PACKAGE_php5-mod-pdo-sqlite):libpthread 
     77           +PHP5_LIBXML:libxml2 
    8178endef 
    8279 
     
    166163ifneq ($(CONFIG_PACKAGE_php5-mod-apc),) 
    167164  CONFIGURE_ARGS+= --enable-apc=shared --disable-apc-mmap --disable-apc-pthreadmutex 
    168   CONFIGURE_LIBS+= -lrt 
    169165else 
    170166  CONFIGURE_ARGS+= --disable-apc 
     
    318314  ifneq ($(CONFIG_PACKAGE_php5-mod-pdo-sqlite),) 
    319315    CONFIGURE_ARGS+= --with-pdo-sqlite=shared,"$(STAGING_DIR)/usr" 
    320     CONFIGURE_LIBS+= -lsqlite3 -lpthread 
    321316  else 
    322317    CONFIGURE_ARGS+= --without-pdo-sqlite 
     
    364359ifneq ($(CONFIG_PACKAGE_php5-mod-sqlite3),) 
    365360  CONFIGURE_ARGS+= --with-sqlite3=shared,"$(STAGING_DIR)/usr" 
    366   CONFIGURE_LIBS+= -lsqlite3 -lpthread 
    367361else 
    368362  CONFIGURE_ARGS+= --without-sqlite3 
Note: See TracChangeset for help on using the changeset viewer.