Changeset 27186


Ignore:
Timestamp:
2011-06-15T23:12:49+02:00 (7 years ago)
Author:
hauke
Message:

package/kernel: Update version dependencies and kmods for linux 3.0

Also disable rtc-core for now since this changed to a bool, now directly
used in the kernel if enabled.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@…>

Location:
trunk/package/kernel/modules
Files:
4 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/kernel/modules/netsupport.mk

    r27150 r27186  
    9090  FILES:= \ 
    9191        $(LINUX_DIR)/drivers/isdn/capi/kernelcapi.ko \ 
    92         $(LINUX_DIR)/drivers/isdn/capi/capifs.ko \ 
    9392        $(LINUX_DIR)/drivers/isdn/capi/capi.ko 
     93 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.0)),1) 
     94  AUTOLOAD:=$(call AutoLoad,30,kernelcapi capi) 
     95 else 
     96  FILES+= $(LINUX_DIR)/drivers/isdn/capi/capifs.ko 
    9497  AUTOLOAD:=$(call AutoLoad,30,kernelcapi capifs capi) 
     98 endif 
    9599endef 
    96100 
     
    479483  SUBMENU:=$(NETWORK_SUPPORT_MENU) 
    480484  TITLE:=PPtP support 
    481   DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39 
     485  DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0 
    482486  KCONFIG:=CONFIG_PPTP 
    483487  FILES:=$(LINUX_DIR)/drivers/net/pptp.ko 
     
    491495  SUBMENU:=$(NETWORK_SUPPORT_MENU) 
    492496  TITLE:=PPPoL2TP support 
    493   DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-l2tp 
     497  DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0:kmod-l2tp 
    494498  KCONFIG:=CONFIG_PPPOL2TP 
    495499  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1) 
     
    654658define KernelPackage/l2tp 
    655659  SUBMENU:=$(NETWORK_SUPPORT_MENU) 
    656   DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39 
     660  DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0 
    657661  TITLE:=Layer Two Tunneling Protocol (L2TP) 
    658662  KCONFIG:=CONFIG_L2TP \ 
  • trunk/package/kernel/modules/other.mk

    r27037 r27186  
    660660define KernelPackage/rtc-core 
    661661  SUBMENU:=$(OTHER_MENU) 
     662  DEPENDS:=@(!LINUX_3_0||BROKEN) 
    662663  TITLE:=Real Time Clock class support 
    663664  KCONFIG:=CONFIG_RTC_CLASS 
  • trunk/package/kernel/modules/usb.mk

    r27010 r27186  
    547547define KernelPackage/usb-serial-wwan 
    548548  TITLE:=Support for GSM and CDMA modems 
    549   DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39 
     549  DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0 
    550550  KCONFIG:=CONFIG_USB_SERIAL_WWAN 
    551551  FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko 
     
    563563define KernelPackage/usb-serial-option 
    564564  TITLE:=Support for Option HSDPA modems 
    565   DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-usb-serial-wwan 
     565  DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0:kmod-usb-serial-wwan 
    566566  KCONFIG:=CONFIG_USB_SERIAL_OPTION 
    567567  FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko 
  • trunk/package/kernel/modules/virtual.mk

    r27010 r27186  
    167167  SUBMENU:=$(VIRTUAL_MENU) 
    168168  TITLE:=Xen PCI device frontend 
    169   DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39 
     169  DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0 
    170170  KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND 
    171171  FILES:=$(LINUX_DIR)/drivers/xen/platform-pci.ko 
Note: See TracChangeset for help on using the changeset viewer.