Changeset 26346


Ignore:
Timestamp:
2011-03-29T00:03:27+02:00 (7 years ago)
Author:
florian
Message:

[package] collected: add modbus plugin.

This enables the modbus plugin of collectd and patches it so it works with the current version of libmodbus

Signed-off-by: Daniel Golle <daniel.golle@…>

Location:
packages/utils/collectd
Files:
1 added
1 edited

Legend:

Unmodified
Added
Removed
  • packages/utils/collectd/Makefile

    r24630 r26346  
    8585        madwifi \ 
    8686        memory \ 
     87        modbus \ 
    8788        mysql \ 
    8889        netlink \ 
     
    190191endif 
    191192 
     193# exception: mod-modbus needs libmodbus 
     194ifneq ($(CONFIG_PACKAGE_collectd-mod-modbus),) 
     195  CONFIGURE_ARGS+= --with-libmodbus="$(STAGING_DIR)/usr" 
     196endif 
     197 
    192198# exception: mod-onewire needs libow-capi 
    193199ifneq ($(CONFIG_PACKAGE_collectd-mod-onewire),) 
     
    270276$(eval $(call BuildPlugin,mysql,MySQL status input,mysql,+PACKAGE_collectd-mod-mysql:libmysqlclient)) 
    271277$(eval $(call BuildPlugin,memory,physical memory usage input,memory,)) 
     278$(eval $(call BuildPlugin,modbus,read variables through libmodbus,modbus,+PACKAGE_collectd-mod-modbus:libmodbus)) 
    272279$(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-netlink:ip @(!LINUX_2_4||BROKEN))) 
    273280$(eval $(call BuildPlugin,network,network input/output,network)) 
Note: See TracChangeset for help on using the changeset viewer.