Changeset 23551


Ignore:
Timestamp:
2010-10-20T19:56:29+02:00 (7 years ago)
Author:
jow
Message:

[package] pppd: use "atmdev" option to select the DSL adapter, this aligns it with br2684ctl and solves #8108

Location:
trunk/package/ppp
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/ppp/Makefile

    r23530 r23551  
    1111PKG_NAME:=ppp 
    1212PKG_VERSION:=2.4.4 
    13 PKG_RELEASE:=12 
     13PKG_RELEASE:=13 
    1414 
    1515PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz 
  • trunk/package/ppp/files/pppoa.sh

    r23530 r23551  
    1010        local config="$2" 
    1111 
    12         local device 
    13         config_get device "$config" device 
     12        local atmdev 
     13        config_get atmdev "$config" atmdev 
    1414 
    1515        local vpi 
     
    3535 
    3636        start_pppd "$config" \ 
    37                 plugin pppoatm.so ${device:+$device.}${vpi:-8}.${vci:-35} \ 
     37                plugin pppoatm.so ${atmdev:+$atmdev.}${vpi:-8}.${vci:-35} \ 
    3838                ${encaps} ${mtu:+mtu $mtu mru $mtu} 
    3939} 
Note: See TracChangeset for help on using the changeset viewer.