Changeset 18813


Ignore:
Timestamp:
2009-12-18T11:51:10+01:00 (8 years ago)
Author:
nico
Message:

[package] wprobe: use a shared DEPENDS between packages, mark them as BROKEN on ps3 & pxcab

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/wprobe/Makefile

    r17749 r18813  
    1919include $(INCLUDE_DIR)/package.mk 
    2020 
     21define Package/wprobe/Default 
     22  DEPENDS:=@LINUX_2_6 @(!(TARGET_ps3||TARGET_pxcab)||BROKEN) 
     23endef 
     24 
    2125define KernelPackage/wprobe 
     26$(call Package/wprobe/Default) 
    2227  SUBMENU:=Network Support 
    23   DEPENDS:=@LINUX_2_6 
    2428  TITLE:=Wireless driver probe infrastructure 
    2529  FILES:= \ 
     
    3337 
    3438define Package/wprobe-util 
     39$(call Package/wprobe/Default) 
    3540  SECTION:=net 
    3641  CATEGORY:=Network 
    37   DEPENDS:=+kmod-wprobe +libnl-tiny 
     42  DEPENDS+=+kmod-wprobe +libnl-tiny 
    3843  TITLE:=Wireless measurement utility 
    3944endef 
     
    4550 
    4651define Package/wprobe-export 
     52$(call Package/wprobe/Default) 
    4753  SECTION:=net 
    4854  CATEGORY:=Network 
    49   DEPENDS:=+wprobe-util 
     55  DEPENDS+=+wprobe-util 
    5056  TITLE:=Wireless measurement data exporter 
    5157endef 
Note: See TracChangeset for help on using the changeset viewer.