Changeset 15779


Ignore:
Timestamp:
2009-05-11T22:40:28+02:00 (9 years ago)
Author:
hauke
Message:

[video-core] With kernel bigger than 2.6.29 compat_ioctl32 will not be build.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/package/kernel/modules/video.mk

    r15242 r15779  
    2424endef 
    2525 
     26ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.29)),1) 
     27define KernelPackage/video-core/2.6 
     28  FILES:= \ 
     29        $(LINUX_DIR)/drivers/media/video/v4l2-common.$(LINUX_KMOD_SUFFIX) \ 
     30        $(LINUX_DIR)/drivers/media/video/v4l1-compat.$(LINUX_KMOD_SUFFIX) \ 
     31        $(LINUX_DIR)/drivers/media/video/videodev.$(LINUX_KMOD_SUFFIX) 
     32  AUTOLOAD:=$(call AutoLoad,60, \ 
     33        v4l1-compat \ 
     34        videodev \ 
     35        v4l2-common \ 
     36  ) 
     37endef 
     38else 
    2639define KernelPackage/video-core/2.6 
    2740  FILES:= \ 
     
    3144        $(LINUX_DIR)/drivers/media/video/videodev.$(LINUX_KMOD_SUFFIX) 
    3245  AUTOLOAD:=$(call AutoLoad,60, \ 
     46        v4l1-compat \ 
     47        videodev \ 
    3348        v4l2-common \ 
    34         v4l1-compat \ 
    3549        compat_ioctl32 \ 
    36         videodev \ 
    3750  ) 
    3851endef 
     52endif 
    3953 
    4054define KernelPackage/video-core/description 
Note: See TracChangeset for help on using the changeset viewer.