Changeset 15205


Ignore:
Timestamp:
2009-04-10T16:40:56+02:00 (9 years ago)
Author:
nico
Message:

merge r14222 to 8.09 (closes: #4077, #4198, #4677)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/8.09/package/kernel/modules/network.mk

    r14097 r15205  
    244244 
    245245 
     246# sit is not selectable on 2.4, but built when ipv6 is enabled 
    246247define KernelPackage/sit 
    247248  SUBMENU:=$(NETWORK_SUPPORT_MENU) 
    248   DEPENDS:=+kmod-iptunnel4 
     249  DEPENDS:=+kmod-ipv6 +LINUX_2_6:kmod-iptunnel4 
    249250  TITLE:=IPv6-in-IPv4 tunnelling 
    250 endef 
    251  
    252 # sit is compiled in the 2.4 ipv6 stack 
    253 define KernelPackage/sit/2.4 
    254   DEPENDS:= @LINUX_2_4 +kmod-ipv6 
    255   KCONFIG:=CONFIG_IPV6 
    256 endef 
    257  
    258 define KernelPackage/sit/2.6 
    259   DEPENDS:= @LINUX_2_6 +kmod-ipv6 +kmod-iptunnel4 
    260   KCONFIG+=CONFIG_IPV6_SIT 
     251  KCONFIG:=CONFIG_IPV6 CONFIG_IPV6_SIT 
    261252  FILES:=$(LINUX_DIR)/net/ipv6/sit.$(LINUX_KMOD_SUFFIX) 
    262253  AUTOLOAD:=$(call AutoLoad,32,sit) 
Note: See TracChangeset for help on using the changeset viewer.