Changeset 12186


Ignore:
Timestamp:
2008-08-06T01:35:30+02:00 (10 years ago)
Author:
nbd
Message:

because of limitations in hostpython, numpy has to depend on python 2.5 development headers and binaries

File:
1 edited

Legend:

Unmodified
Added
Removed
  • packages/lang/numpy/Makefile

    r11532 r12186  
    3131 
    3232define Build/Compile 
    33         cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) $(STAGING_DIR)/host/bin/python ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr" 
     33        cd $(PKG_BUILD_DIR) ; $(CONFIGURE_VARS) $(MAKE_VARS) python2.5 ./setup.py install --prefix="$(PKG_INSTALL_DIR)/usr" 
    3434        sed -i "s/UCS4/UCS2/g" $(PKG_INSTALL_DIR)/usr/lib/python2.5/site-packages/numpy/core/multiarray.so 
    3535endef 
     
    4141 
    4242$(eval $(call BuildPackage,numpy)) 
     43 
     44define Require/python25-dev 
     45[ -e /usr/include/python2.5/pyconfig.h ] 
     46endef 
     47 
     48$(eval $(call Require,python25-dev, \ 
     49        Please install Python 2.5 (including development headers and libraries) \ 
     50)) 
Note: See TracChangeset for help on using the changeset viewer.