Ticket #20515: packages-enable-collectd-nut.patch

File packages-enable-collectd-nut.patch, 1.1 KB (added by dwmw2, 2 years ago)

Enable collectd-mod-nut subpackage

  • utils/collectd/Makefile

    diff --git a/utils/collectd/Makefile b/utils/collectd/Makefile
    index 61b05a8..b638372 100644
    a b COLLECTD_PLUGINS_DISABLED:= \ 
    5555        notify_desktop \ 
    5656        notify_email \ 
    5757        numa \ 
    58         nut \ 
    5958        openvz \ 
    6059        oracle \ 
    6160        perl \ 
    COLLECTD_PLUGINS_SELECTED:= \ 
    112111        network \ 
    113112        nginx \ 
    114113        ntpd \ 
     114        nut \ 
    115115        olsrd \ 
    116116        onewire \ 
    117117        openvpn \ 
    $(eval $(call BuildPlugin,netlink,netlink input,netlink,+PACKAGE_collectd-mod-ne 
    303303$(eval $(call BuildPlugin,network,network input/output,network)) 
    304304$(eval $(call BuildPlugin,nginx,nginx status input,nginx,+PACKAGE_collectd-mod-nginx:libcurl)) 
    305305$(eval $(call BuildPlugin,ntpd,NTP daemon status input,ntpd,)) 
    306 #$(eval $(call BuildPlugin,nut,UPS monitoring input,nut,+PACKAGE_collectd-mod-nut:nut)) 
     306$(eval $(call BuildPlugin,nut,UPS monitoring input,nut,+PACKAGE_collectd-mod-nut:nut)) 
    307307$(eval $(call BuildPlugin,olsrd,OLSRd status input,olsrd,)) 
    308308$(eval $(call BuildPlugin,onewire,onewire sensor input,onewire,+PACKAGE_collectd-mod-onewire:libow-capi @BROKEN)) 
    309309$(eval $(call BuildPlugin,openvpn,OpenVPN traffic/compression input,openvpn,))