Modify

Opened 8 years ago

Closed 8 years ago

#7082 closed defect (fixed)

Switch not properly configured on WRT54G v2.0 - workaround doesnt work in Backfire anymore

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Backfire 10.03
Component: base system Version: Backfire 10.03 RC3
Keywords: Cc:

Description

The initialization scripts only configure the used VLANs, but don't clear the port mappings for the remaining VLANs, which then still have the default mapping:
e.g.:

cat /proc/switch/eth0/vlan/14/ports
0       1       2       3       4       5t

This is a problem since the hardware switch passes around broadcast packets between all ports, thus not cleanly separating the VLANs from each other...

With Kamikaze I could workaround this issue by explicitly removing all ports from unused VLANs:

network.eth0=switch
network.eth0.vlan0=2 3 4 5
network.eth0.vlan1=0 5
network.eth0.vlan2=1 5
network.eth0.vlan3=
network.eth0.vlan4=
network.eth0.vlan5=
network.eth0.vlan6=
network.eth0.vlan7=
network.eth0.vlan8=
network.eth0.vlan9=
network.eth0.vlan10=
network.eth0.vlan11=
network.eth0.vlan12=
network.eth0.vlan13=
network.eth0.vlan14=
network.eth0.vlan15=

But with Backfire this doesn't seem to work anymore

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed with r20717

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.