Modify

Opened 8 years ago

Closed 8 years ago

#7058 closed defect (fixed)

[x86][rc3] usb modules do not work

Reported by: flux Owned by: developers
Priority: high Milestone: Backfire 10.03
Component: packages Version: Backfire 10.03 RC3
Keywords: Cc:

Description

I really hate to open this one because there was one already #6873. But it seems like it won't be fixed any time soon. Marking the bug as fixed is of cause a solution but it does not improve the situation, does it?

How to reproduce:

  1. take openwrt-x86-ext2.image.gz from http://downloads.openwrt.org/backfire/10.03-rc3/x86/. Unpack it to /whatever/
  2. dd of=/dev/sd(whatever) if=/whatever/openwrt-x86-ext2.image
  3. opkg update; opkg install kmod-usb-ohci

Please test it right this time

usb_storage: Unknown symbol usb_alloc_urb
usb_storage: Unknown symbol usb_free_urb
usb_storage: Unknown symbol usb_register_driver
usb_storage: Unknown symbol usb_sg_init
usb_storage: Unknown symbol usb_sg_cancel
usb_storage: Unknown symbol usb_reset_device
usb_storage: Unknown symbol usb_submit_urb
usb_storage: Unknown symbol usb_control_msg
usb_storage: Unknown symbol usb_deregister
usb_storage: Unknown symbol usb_lock_device_for_reset
usb_storage: Unknown symbol usb_unlink_urb
usb_storage: Unknown symbol usb_kill_urb
usb_storage: Unknown symbol usb_buffer_free
usb_storage: Unknown symbol usb_reset_endpoint
usb_storage: Unknown symbol usb_sg_wait
usb_storage: Unknown symbol usb_buffer_alloc
usbcore: Unknown symbol utf16s_to_utf8s
uhci_hcd: Unknown symbol usb_hcd_resume_root_hub
uhci_hcd: Unknown symbol usb_hcd_pci_probe
uhci_hcd: Unknown symbol usb_hcd_unlink_urb_from_ep
uhci_hcd: Unknown symbol usb_disabled
uhci_hcd: Unknown symbol usb_hcd_check_unlink_urb
uhci_hcd: Unknown symbol usb_hcds_loaded
uhci_hcd: Unknown symbol usb_calc_bus_time
uhci_hcd: Unknown symbol usb_hcd_link_urb_to_ep
uhci_hcd: Unknown symbol usb_hcd_giveback_urb
uhci_hcd: Unknown symbol usb_hcd_poll_rh_status
uhci_hcd: Unknown symbol usb_hcd_pci_remove
uhci_hcd: Unknown symbol usb_root_hub_lost_power

raise the priority this time

Attachments (0)

Change History (7)

comment:1 follow-up: Changed 8 years ago by jow

Is kmod-nls-base installed?

comment:2 in reply to: ↑ 1 ; follow-ups: Changed 8 years ago by flux

Replying to jow:

Is kmod-nls-base installed?

yes it is installed. But this was a good tip, thank you. The missing package is kmod-nls-utf8. But how could I detect this from the error description? Shouldn't be a dependency to it from kmod-usb-core?

comment:3 in reply to: ↑ 2 Changed 8 years ago by anonymous

Shouldn't be a dependency to it from kmod-usb-core?

or add it into the image by default together with the kmod-nls-base

comment:4 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by nico

Replying to flux:

[...] The missing package is kmod-nls-utf8. [...]

No, it's not.

$ grep -r utf16s_to_utf8s build_dir/linux-x86_generic/linux-2.6.32.10/fs/nls/
build_dir/linux-x86_generic/linux-2.6.32.10/fs/nls/nls_base.c:int utf16s_to_utf8s(const wchar_t *pwcs, int len, enum utf16_endian endian,
build_dir/linux-x86_generic/linux-2.6.32.10/fs/nls/nls_base.c:EXPORT_SYMBOL(utf16s_to_utf8s);

So the dependency on kmod-nls-base is correct.

Can you try re-installing the following modules in the specified order ?

  1. kmod-nls-base
  2. kmod-usb-core
  3. kmod-usb2
  4. kmod-usb-ohci

comment:5 in reply to: ↑ 4 Changed 8 years ago by anonymous

Can you try re-installing the following modules in the specified order ?

  1. kmod-nls-base
  2. kmod-usb-core
  3. kmod-usb2
  4. kmod-usb-ohci

I removed all usb modules and all nls modules. Rebooted (necessary). Installed kmod-usb2 and got the errors. Rebooted again and installed kmod-usb-storage - no error messages and everything works. Could it be that kmod-nls-base is somehow not configured at all before the fist reboot? Because if I'd install more usb modules before the first reboot then I'd get all the errors for every package that has dependecny to the kmod-nls-base.

And yes kmod-nls-utf8 is not needed.

comment:6 Changed 8 years ago by flux

maybe this problem is also related to this one #7057

comment:7 Changed 8 years ago by nico

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in [20686], thanks !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.