Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6965 closed enhancement (fixed)

netatalk package is incomplete.

Reported by: jake1981 <oskari.rauta@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Netatalk package seems to be lacking necessary UAMS libraries used while connecting.
There's also no configuration file of any sort included in the package - and it doesn't create folders where configurations should initially be kept. Also during configuration it was set that libraries are kept on /etc/netatalk - I changed this to /usr/lib..

Patch is included which adds to package:

  • necessary uams libraries (without these, shares cannot be used) in /usr/lib
  • sample set of settings
  • init script

Attachments (2)

netatalk.patch (28.8 KB) - added by jake1981 <oskari.rauta@…> 8 years ago.
patch
netatalk.2.patch (28.3 KB) - added by jake1981 <oskari.rauta@…> 8 years ago.
new patch - previous patch patched also freeradius2 which I will put another ticket for.. This replaces previous patch(es).

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by jake1981 <oskari.rauta@…>

patch

Changed 8 years ago by jake1981 <oskari.rauta@…>

new patch - previous patch patched also freeradius2 which I will put another ticket for.. This replaces previous patch(es).

comment:2 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in r20539, thanks!

comment:3 Changed 8 years ago by jake1981 <oskari.rauta@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Even though all necessary files are there - this just doesn't work. I can browse the list of shares, but when opening shares I am not capable of writing any files or even see filenames or open any files - so this thing is broken badly.

If you check the project page, it says this is early beta and it comes with a warning:
Please note that this release has not yet received widespread testing. It should therefore *not* be used in production.

If you need a working afp file server software, you need to use earlier one and for now until this gets fixed, openwrt should go back to 2.0.5 which requires appletalk kernel module to work, but hey, it atleast does what it's supposed to do :)

Here's a link to previous version with new patch that downgrades trunk from 2.1 to 2.0.5..
/ticket/6619.html

comment:4 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with r20546.

comment:5 Changed 8 years ago by Frank Lahm

Netatalk 2.0.5 doesn't require an Appletalk kernel module if you're only interested in afpd and not in atalkd/papd.

comment:6 Changed 8 years ago by jake1981 <oskari.rauta@…>

  • Resolution fixed deleted
  • Status changed from closed to reopened

Thanks Frank - I removed kmod-appletalk dependancy from package and added to description a suggestion to install kmod-appletalk if user needs also atalkd/papd - not just afpd - and made a new patch.

comment:7 Changed 8 years ago by jake1981 <oskari.rauta@…>

Sorry - wasn't supposed to send patch to this ticket ( sending it to ticket of 2.0.5 ) - so no reason to reopen ticket.

Reason for re-opening was invalid.

comment:8 Changed 8 years ago by florian

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.