Modify

Opened 8 years ago

Closed 8 years ago

#6874 closed defect (fixed)

kmod-b43 won't load

Reported by: flux Owned by: hauke
Priority: normal Milestone: Backfire 10.03
Component: packages Version: Kamikaze trunk
Keywords: Cc:

Description (last modified by hauke)

root@OpenWrt:/# dmesg | grep b43
b43: Unknown symbol ssb_device_is_enabled
b43: Unknown symbol ssb_pmu_set_ldo_paref
b43: Unknown symbol ssb_pcicore_dev_irqvecs_enable
b43: Unknown symbol ssb_bus_may_powerdown
b43: Unknown symbol ssb_dma_free_consistent
b43: Unknown symbol ssb_set_devtypedata
b43: Unknown symbol ssb_device_disable
b43: Unknown symbol ssb_pmu_set_ldo_voltage
b43: Unknown symbol ssb_dma_alloc_consistent
b43: Unknown symbol ssb_dma_set_mask
b43: Unknown symbol ssb_device_enable
b43: Unknown symbol ssb_driver_unregister
b43: Unknown symbol __ssb_driver_register
b43: Unknown symbol ssb_bus_powerup
b43: Unknown symbol ssb_dma_translation

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by anonymous

x86 platform

comment:2 follow-up: Changed 8 years ago by hauke

  • Description modified (diff)

I am unable to reproduce this error. How did you installed kmod-b43? It seems to me that kmod-ssb is missing.

comment:3 in reply to: ↑ 2 Changed 8 years ago by anonymous

Replying to hauke:

I am unable to reproduce this error. How did you installed kmod-b43? It seems to me that kmod-ssb is missing.

I've installed it with - opkg install kmod-b43
A missing dependency?

comment:4 Changed 8 years ago by anonymous

kmod-b43 package has only one dependency -

Package: kmod-b43
Version: 2.6.32.9+2010-02-16-3
Depends: kernel (=2.6.32.9-1), kmod-mac80211 
Provides: 
Source: package/mac80211
Section: kernel
...

it should also have a dependency to the kmod-ssb

comment:5 Changed 8 years ago by thepeople

  • Owner changed from developers to hauke
  • Status changed from new to assigned

comment:6 Changed 8 years ago by hauke

  • Resolution set to fixed
  • Status changed from assigned to closed

This should be fixed in r20553

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.