Modify

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#6856 closed defect (fixed)

Crosscompile Python-2.6.4 doesn't work

Reported by: drent Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze trunk
Keywords: Python-2.6.4 cross compile Cc:

Description

The "/usr/include" path is included so gcc 4.3.3 stops cross-compilation. This happens after latest python changes.

...  -DPy_BUILD_CORE  -I/usr/include -c ./Modules/zlibmodule.c -o Modules/zlibmodule.o
cc1: warning: include location "/usr/include" is unsafe for cross-compilation
In file included from /usr/include/features.h:378,
                 from /usr/include/limits.h:27,
                 from Include/Python.h:19,
                 from ./Modules/zlibmodule.c:7:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
In file included from Include/unicodeobject.h:57,
                 from Include/Python.h:85,
                 from ./Modules/zlibmodule.c:7:
/usr/include/ctype.h:82: warning: '__const' attribute directive ignored
/usr/include/ctype.h:84: warning: '__const' attribute directive ignored
/usr/include/ctype.h:86: warning: '__const' attribute directive ignored
make[4]: *** [Modules/zlibmodule.o] Error 1

Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description Changed 8 years ago by b.sander

Replying to drent:

The "/usr/include" path is included so gcc 4.3.3 stops cross-compilation. This happens after latest python changes.
make[4]: * [Modules/zlibmodule.o] Error 1

You'll find that was caused by the 110-enable-zlib.patch

--- Python-2.6.4/Modules/Setup.dist	2008-11-27 11:15:12.000000000 +0100
+++ Python-2.6.4/Modules/Setup.dist	2010-02-27 04:14:15.000000000 +0100
@@ -460,7 +460,7 @@
 # Andrew Kuchling's zlib module.
 # This require zlib 1.1.3 (or later).
 # See http://www.gzip.org/zlib/
-#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
+zlib zlibmodule.c -L$(exec_prefix)/lib -lz
 
 # Interface to the Expat XML parser
 #

Deleting -I$(prefix)/include should fix it.

comment:2 Changed 8 years ago by lars

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r20251.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.