Modify

Opened 8 years ago

Closed 5 years ago

Last modified 4 years ago

#6804 closed defect (worksforme)

brcm-2.4 & brcm47xx : process '/bin/ash --login' exited. Scheduling for restart.

Reported by: nico Owned by: developers
Priority: response-needed Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: busybox, init, serial, brcm-2.4, brcm47xx Cc:

Description

On brcm-2.4 & brcm47xx (and maybe others), logread shows a bunch of :

Jan  1 00:02:55 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1684) exited. Scheduling for restart.
Jan  1 00:02:55 OpenWrt daemon.info init: starting pid 1689, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:02:56 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1689) exited. Scheduling for restart.
Jan  1 00:02:56 OpenWrt daemon.info init: starting pid 1694, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:02:57 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1694) exited. Scheduling for restart.
Jan  1 00:02:57 OpenWrt daemon.info init: starting pid 1699, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:02:57 OpenWrt authpriv.info dropbear[1704]: Child connection from 192.168.1.254:58113
Jan  1 00:02:58 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1699) exited. Scheduling for restart.
Jan  1 00:02:58 OpenWrt daemon.info init: starting pid 1705, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:02:59 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1705) exited. Scheduling for restart.
Jan  1 00:02:59 OpenWrt daemon.info init: starting pid 1710, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:00 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1710) exited. Scheduling for restart.
Jan  1 00:03:00 OpenWrt daemon.info init: starting pid 1715, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:01 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1715) exited. Scheduling for restart.
Jan  1 00:03:01 OpenWrt daemon.info init: starting pid 1720, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:02 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1720) exited. Scheduling for restart.
Jan  1 00:03:02 OpenWrt daemon.info init: starting pid 1725, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:03 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1725) exited. Scheduling for restart.
Jan  1 00:03:03 OpenWrt daemon.info init: starting pid 1730, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:03 OpenWrt authpriv.notice dropbear[1704]: password auth succeeded for 'root' from 192.168.1.254:58113
Jan  1 00:03:04 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1730) exited. Scheduling for restart.
Jan  1 00:03:04 OpenWrt daemon.info init: starting pid 1740, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:05 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1740) exited. Scheduling for restart.
Jan  1 00:03:05 OpenWrt daemon.info init: starting pid 1745, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:06 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1745) exited. Scheduling for restart.
Jan  1 00:03:06 OpenWrt daemon.info init: starting pid 1750, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:07 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1750) exited. Scheduling for restart.
Jan  1 00:03:07 OpenWrt daemon.info init: starting pid 1755, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:08 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1755) exited. Scheduling for restart.
Jan  1 00:03:08 OpenWrt daemon.info init: starting pid 1761, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:09 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1761) exited. Scheduling for restart.
Jan  1 00:03:09 OpenWrt daemon.info init: starting pid 1766, tty '/dev/ttyS0': '/bin/ash --login'
Jan  1 00:03:10 OpenWrt daemon.info init: process '/bin/ash --login' (pid 1766) exited. Scheduling for restart.
Jan  1 00:03:10 OpenWrt daemon.info init: starting pid 1771, tty '/dev/ttyS0': '/bin/ash --login'

source:trunk/package/busybox/patches/001-init_avoid_loop_opening_tty.patch doesn't work anymore and needs fixing

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by nico

You can fix it on a running system with the following change :

--- /etc/inittab.orig	Thu Jan  1 00:08:21 1970
+++ /etc/inittab	Thu Jan  1 00:07:30 1970
@@ -1,5 +1,5 @@
 ::sysinit:/etc/init.d/rcS S boot
 ::shutdown:/etc/init.d/rcS K stop
 tts/0::askfirst:/bin/ash --login
-ttyS0::askfirst:/bin/ash --login
+#ttyS0::askfirst:/bin/ash --login
 tty1::askfirst:/bin/ash --login

and tell init to reload the file :

root@OpenWrt:~# kill -HUP 1

}}}

comment:2 Changed 8 years ago by nico

Can't reproduce anymore on a fresh trunk, brcm-2.4, r21556

comment:3 Changed 7 years ago by micdah@…

I was seeing this problem running Kamikaze (r18961) on a x86 based machine. The above mentioned patch/diff fixed this problem though.

comment:4 Changed 7 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 7 years ago by dev@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I still see this problem w/ the current backfire rc4 build on my wrt54g v1.1.

The above patch was never committed. It's just a workaround to hide the problem though. Why isn't "askfirst" working like it should?

By the way, speaking of inittab, another patch was sent to the mailing list a long time ago to change the "tty1" line to "ttyS1".

https://lists.openwrt.org/pipermail/openwrt-devel/2009-November/005228.html

That change should be put in when this ash/askfirst problem is fixed.

comment:6 Changed 7 years ago by jow

  • Priority changed from normal to response-needed

Is this still the case with RC5 ?

comment:7 Changed 7 years ago by dev@…

I still see this problem w/ backfire rc5 on my wrt54g v1.1.

comment:8 Changed 6 years ago by admin@…

I have Backfire 10.03.1 r30807 on brcm47xx chipset and I see process '/bin/ash --login' being endlessly restarted. I have build my own image from Backfire svn trunk.

comment:9 Changed 5 years ago by florian

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:10 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.