Modify

Opened 9 years ago

Closed 9 years ago

#4926 closed defect (fixed)

rtorrent-0.8.4_r1087 compile turn the host unresponsive

Reported by: bghome@… Owned by: nico
Priority: highest Milestone: Kamikaze 8.09.1
Component: packages Version: Kamikaze 8.09
Keywords: rtorrent compile error failure memory unresponsive Cc:

Description

In openwrt 8.09 revision 15213, rtorrent compile process fed all my memory (1GB RAM + 300 MB swap). I tried to compile it two more times, but the same thing happened. After that I issued the

sysctl -w vm.overcommit_memory=2

command to limit kernel resources. Now the compiling process stops with segmentation fault (see the attached rtorrent-compile.log).

Attachments (1)

rtorrent-compile.log (31.6 KB) - added by bghome@… 9 years ago.
make package/feeds/packages/rtorrent-compile V=99 output

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by bghome@…

make package/feeds/packages/rtorrent-compile V=99 output

comment:1 Changed 9 years ago by anonymous

try to increase your swap file ....

comment:2 Changed 9 years ago by anonymous

.. or use ctorrent :)

comment:3 Changed 9 years ago by bghome@…

I don't like ctorrent.

comment:4 follow-up: Changed 9 years ago by sav

build gcc 4.3.3 (for kernel 2.6), install in board rebuilt libstdc++, libsigc++, libtorrent, libgcc_s_4.3.3, and after that all works very well, is checked up on Wl500gpV1 and Wl500gpV1 with kernel 2.4.

comment:5 Changed 9 years ago by anonymous

And rtorrent it is naturally necessary to establish too ;-))

comment:6 in reply to: ↑ 4 Changed 9 years ago by bghome@…

Replying to sav:

build gcc 4.3.3 (for kernel 2.6), install in board rebuilt libstdc++, libsigc++, libtorrent, libgcc_s_4.3.3, and after that all works very well, is checked up on Wl500gpV1 and Wl500gpV1 with kernel 2.4.

I had installed gcc-4.3 and libstdc++6 packages from Debian sid repositories, so I suppose they are operate well. I have rebuilt the toolchain and all other packages, but the same error message appeared during rtorrent compilation. Do you think the problem is related to 64 bit libraries?

comment:7 follow-up: Changed 9 years ago by sav

Where installed gcc-4.3 and libstdc++6 packages from Debian sid repositories? In board or computer?
What board? What OS computer?
It is not necessary to establish alternative libraries on computer!

Do how I ;-))

get svn OpenWrt in computer.
make menuconfig

We choose brcm47[2.6] (Or what at you there board, but kernel version 2.6)
gcc - 4.3.3
binutils 2.19.1
uclibc 0.9.29

make package/symlinks

make menuconfig
choose net/rtorrent

make
build...

Install in board rebuild packages - libstdcpp, libsigcxx, libgcc_4.3.3, libtorrent,
rtorrent

And all fine works, works and works OK ;-)))

comment:8 Changed 9 years ago by sav

Checked up on Wl500gpv2(kernel 2.4) - works well

comment:9 in reply to: ↑ 7 Changed 9 years ago by anonymous

Replying to sav:

Where installed gcc-4.3 and libstdc++6 packages from Debian sid repositories? In board or computer?
What board? What OS computer?
It is not necessary to establish alternative libraries on computer!

Do how I ;-))

get svn OpenWrt in computer.
make menuconfig

We choose brcm47[2.6] (Or what at you there board, but kernel version 2.6)
gcc - 4.3.3
binutils 2.19.1
uclibc 0.9.29

make package/symlinks

make menuconfig
choose net/rtorrent

make
build...

Install in board rebuild packages - libstdcpp, libsigcxx, libgcc_4.3.3, libtorrent,
rtorrent

And all fine works, works and works OK ;-)))

Well, thanks for your instructions! I also have Asus WL500gpv1 with 2.4.x kernel.
So finally I managed to compile libtorrent and rtorrent like this:

  • I deleted the whole openwrt source dir and checked out from svn again
  • selected brcm47xx[2.6] target system and the packages I like
  • but the configure script exited at both libtorrent and rtorrent, because it complained about missing libopenssl and libsigc++-2.0 libraries

so I had to change the Makefile of them to specify the location of the .pc files for pkg-config
libtorrent/Makefile:

...
CONFIGURE_ARGS+= \
	--enable-shared \
	--enable-static \
	--enable-aligned \
	--disable-debug \
	--enable-openssl="$(STAGING_DIR)/usr" \
	, \
	PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
...

and rtorrent/Makefile:

...
CONFIGURE_ARGS+= \
	--enable-shared \
	--disable-static \
	--disable-debug \
	--with-xmlrpc-c \
	, \
	PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
...
  • after that changes they compiled succesfully

I will re-flash the router with the new kernel and try new rtorrent at the weekend.

comment:10 Changed 9 years ago by nico

  • Milestone changed from Kamikaze to Kamikaze 8.09.1
  • Owner changed from developers to nico
  • Status changed from new to assigned
  • Version changed from Trunk to Kamikaze 8.09

comment:11 Changed 9 years ago by nico

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [15871], thanks for reporting!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.