Modify

Opened 9 years ago

Closed 9 years ago

#4592 closed defect (fixed)

No gsm codec translation in asterisk14

Reported by: ldpaniak Owned by: zandbelt
Priority: high Milestone: Kamikaze 8.09.1
Component: packages Version: Kamikaze 8.09
Keywords: asterisk gsm asterisk14 Cc:

Description

Hi,

There seems to be a problem with asterisk14 in 8.09RC2. There is no gsm codec translation. This makes the voicemail package unusable as all sounds are in gsm. Default configuration in modules.conf specifies GSM/PCM16 translation is enabled, but core show translation does not include a gsm/ulaw entry.

A trunk build from from early January (sorry no revision number at the moment) has gsm translation and worked well.

Attachments (1)

openwrt-packages-asterisk-1.4.23.1-gsmlib.patch (555 bytes) - added by zandbelt 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by sburney@…

I'm seeing the same issue.

comment:2 Changed 9 years ago by zandbelt

  • Owner changed from developers to zandbelt
  • Status changed from new to assigned

bummer, that is even in the 8.09 release; it is due to a mismatch in libgsm availability at build time and the runtime package dependencies; I'll create a fix and make builds; which platform do you need if for?

comment:3 Changed 9 years ago by sburney@…

As the project was pretty urgent I ended up using White Russian 0.9 in which is worked perfectly, but in future I'll be be using brcm-2.4 or brcm47xx.

Thanks!

comment:4 Changed 9 years ago by anonymous

i met the same problem.

I just rebulding the openwrt img, everything is ok. the following is my step:
1, install kamikaze_8.09
2, make menuconfig and select the asterisk14 to build a module.

  1. make it

4, use tar command extract the codec_gsm.so from new asterisk14_1.4.23.1-1_mipsel.ipk file

  1. replace codec_gsm.so, everything is ok.

comment:5 Changed 9 years ago by zandbelt

a simpler workaround would be to just install libgsm because the gsm module was built with a dependency on that; alternatively I have put up packages with native gsm support at: http://members.home.nl/hans.zandbelt/openwrt/

comment:6 Changed 9 years ago by zandbelt

binary packages with built-in internal gsm codecs (no dependency on libgsm) are at:
http://members.home.nl/hans.zandbelt/openwrt/8.09/

comment:7 Changed 9 years ago by ldpaniak

Just to clarify, what architecture and kernel version are the posted Asterisk packages for?

I was looking for BCM947xx [2.6] packages to run on an Asus WL500gP

Thanks.

comment:8 Changed 9 years ago by nico

  • Version set to Kamikaze 8.09

comment:9 Changed 9 years ago by nico

  • Milestone changed from Kamikaze to Kamikaze 8.09.1
  • Resolution set to fixed
  • Status changed from assigned to closed

Applied in [15161]

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.