Modify

Opened 9 years ago

Closed 8 years ago

Last modified 4 years ago

#4484 closed defect (fixed)

softled = 1 causes packetloss on AR5005G

Reported by: wbreyha@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Kamikaze trunk
Keywords: madwifi, softled, ledpin, packet loss Cc:

Description

Hi!

Changeset 12709 introduced the possibility to turn off softled... and introduced the unconditional default value 1. It took me about 2 weeks to find the cause of my high packet loss which rendered my AP useless since I upgraded from 7.0x to 8.09rc1.

And no, it's not 1. of April;-) Setting softled=1 and ledpin=0 on my Atheros WLAN Card...

00:0e.0 168c:001a Ethernet controller: Atheros Communications, Inc.
 AR5005G 802.11abg NIC (rev 01)

renders it useless instantly on several madwifi releases I tried (about 7 including both provided by 8.09rc1).

I've filed a bug at madwifi-project, too. Maybe they can prevent the driver from setting these values on this device-ID.
http://madwifi-project.org/ticket/2230

Since setting softled=1 and ledpin=1 works, too, there're two possible solutions IMO...
*) get the default for softled from /proc/sys/dev.. driver default or at least set it to "0"
*) set ledpin=1 by default if softled is set to "1". don't know if that causes havoc on other devices.

Regards, Wolfgang Breyha

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by wbreyha@…

this should do the trick...

--- madwifi.sh.orig	Thu Jan 22 13:47:00 2009
+++ madwifi.sh	Thu Jan 22 13:53:15 2009
@@ -172,7 +172,12 @@
 		config_get_bool antdiv "$device" diversity
 		config_get antrx "$device" rxantenna
 		config_get anttx "$device" txantenna
-		config_get_bool softled "$device" softled 1
+		if [ -r /proc/sys/dev/$device/softled ]; then
+			softled_default="$(cat /proc/sys/dev/$device/softled)"
+		else
+			softled_default=1
+		fi
+		config_get_bool softled "$device" softled $softled_default
 
 		devname="$(cat /proc/sys/dev/$device/dev_name)"
 		antgpio=

comment:2 Changed 9 years ago by ott@…

I can confirm this. Is anyone going to fix this?

comment:3 Changed 9 years ago by acoul <alex at ozo.com>

here is a relative forum thread

comment:4 Changed 8 years ago by jorik@…

I can confirm this too: OpenWRT 8.09.2-RC2 on Asus WL-500gP with a gigabyte card (Atheros 5212) needs softled to be set to 0 in order to work.

comment:5 Changed 8 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed
  • Version set to Kamikaze trunk

fixed in r20195

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.