Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18099 closed defect (wontfix)

ar71 reaver broken

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Attitude Adjustment 12.09.1
Component: packages Version: Trunk
Keywords: Cc:

Description

using latest AA revision with ar71 platform reaver results in continous failed WSC transmissions. another bug is it doesn't associate if the aireplay-ng isn't used for association.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

Reaver is not part of any OpenWrt maintaiend repository.

comment:2 Changed 3 years ago by anonymous

this is compat-wireless bug that won't make it run as expected. somebody made a patch to speed it up:

--- reaver-r113.orig/src/exchange.c	2012-10-13 20:20:23.452675557 +0200
+++ reaver-r113/src/exchange.c	2012-10-13 20:29:39.741682088 +0200
@@ -273,7 +273,12 @@
 		send_termination();
 		stop_timer();
 	}
-	
+
+	if (get_external_association()) 
+	{
+		deauthenticate();
+	}
+
 	return ret_val;
 }

this won't work if you change MAC address of client interface or if you bring it down.

there is another patch that fixed wash in client+monitor mode but airodump/aireplay still throw out fixed channel mon0: -1 error.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.